米尔科技提醒您:您的浏览器版本过低或者使用了兼容模式,为了获得更好的浏览体验,建议使用IE10以上的浏览器或使用极速模式。 请升级浏览器以获得更好的体验!

DS-5通过gdbserver调试多线程应用程序有何条件?

问题类别: > DS-5 浏览次数:3447
发布日期:2015/7/13 14:48:13 文章来源:米尔科技
回复日期:2020/12/18 9:47:53

环境说明

DS-5 android

分析描述

DS-5通过gdbserver调试多线程应用程序有何条件?

问题解答

1、gdbserver版本必须高于6.8版本(不包含6.8);
2、android应用程序中,NDK库必须为2.2,2.3,3.x.x,4.0。
3、调试ARM linux kernel内核时,其版本必须为2.6.28及其以上;
4、使用ARM Steamline时,Linux 内核必须大于3.x版本;
5、SMP系统上的app调试,kernel内核版本必须为2.6.36及其以上版本。

ARM官方解释:http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.arn0006f/index.html